curl: (51) SSL peer certificate or SSH remote key was not OK

Ich hatte seit einigen Tagen Probleme, dass mein Backup mit Tartarus immer den Fehler "curl: (51) SSL peer certificate or SSH remote key was not OK" auswarf und damit das Backup abgebrochen wurde.

Das Hauptproblem ist, dass der Server auf dem das Backup gemacht werden muss mit dem SSL Key vom Backup Server nicht klar kommt. 

Weiterlesen: curl: (51) SSL peer certificate or SSH remote key was not OK

/arm-none-linux-gnueabi-gcc: No such file or directory

Da ich für ein neues Projekt einen arm Crosscompiler benötige, dachte ich mir heute, ich setze schnell eine neue VM auf mit dem akutellen Ubuntu 14.04 .. alles hat soweit ohne Probleme geklappt, doch dann "/arm-none-linux-gnueabi-gcc: No such file or directory"

Weiterlesen: /arm-none-linux-gnueabi-gcc: No such file or directory

Linux_Keyboard_Layout

Nach einer frischen Debian Installation geht es mir oft so, dass "z" ist das "y" und sonst einfach vieles verdreht ... "patsch" okeee wieder mal ein US Layout insatlliert ...

Dies kann man aber unter Debian 6.0 Squeeze ganz leicht umstellen ...
einfach mit dem Lieblings Editor die Datei /etc/default/keyboard bearbeiten, dort die Zeile
XKBLAYOUT =“us” in, XKBLAYOUT =“de” umwandeln, speichern.
Zum schluss noch ein /etc/init.d/keyboard-setup restart ... schon ist alles auf dem Deutschen Tastatur Layout.


Aber Achtung !!!
Wenn ihr euer Passwort mit Sonderzeichen oder z oder y schon vergeben habt ... denkt daran, dass dies im Alten Layout passiert ist!

*** Warning - bad CRC or NAND, using default environment

Wenn man den Uboot frisch auf einen Arm spielt kommt beim Booten eine unschöne Fehlermeldung wo manche doch sehr verunsichert ...

*** Warning - bad CRC or NAND, using default environment

Das ganze ist sehr einfach auf der Seriellen Promt zu beheben und zwar mit saveenv.

 

U-Boot> saveenv <\r><\n>
Saving Environment to NAND...<\r><\n>
Erasing Nand...<\r><\n>
<\r>Erasing at 0xc0000 -- 100% complete.<\r><\n>
Writing to Nand... done<\r><\n>
U-Boot> <\r><\n>

 

Das Problem ist hier der Uboot benötigt ein paar Umgebungsvariablen, welche natürlich in einem leeren flash noch nicht gesetzt sind ...

 

Nun noch ein neustart und die Fehlermeldung ist weg :)


 

 

Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Nutzung unserer Dienste erklären Sie sich damit einverstanden, dass wir Cookies verwenden.
Weitere Informationen Ok